martes, 22 de enero de 2013

CCNA 4: 1.4.1



R1
R1#show run
!<output omitted>
!
hostname R1
!
!
enable secret class
!
!
no ip domain lookup
!
interface FastEthernet0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
no shutdown
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/1.12
encapsulation dot1Q 12
ip address 10.12.12.1 255.255.255.0
!
interface FastEthernet0/1.13
encapsulation dot1Q 13
ip address 10.13.13.1 255.255.255.0
!
interface Serial0/0/0
ip address 10.1.1.1 255.255.255.0
no fair-queue
clockrate 64000
no shutdown
!
interface Serial0/0/1
no ip address
shutdown
!
router eigrp 10
network 10.1.1.0 0.0.0.3
network 10.12.12.0 0.0.0.255
network 10.13.13.0 0.0.0.255
network 192.168.10.0
no auto-summary
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0
network 10.12.12.0 0.0.0.255 area 0
network 10.13.13.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
!
router rip
version 2
network 10.0.0.0
network 192.168.10.0
no auto-summary
!!
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end
R2
R2#show run
!<output omitted>
!
hostname R2
!
enable secret class
!
no ip domain lookup
!
interface FastEthernet0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
no shutdown
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/1.12
encapsulation dot1Q 12
ip address 10.12.12.2 255.255.255.0
!
interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 10.2.2.1 255.255.255.252
no shutdown
!
router eigrp 10
network 10.1.1.0 0.0.0.3
network 10.2.2.0 0.0.0.3
network 10.12.12.0 0.0.0.255
network 192.168.20.0
no auto-summary
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0
network 10.2.2.0 0.0.0.3 area 0
network 10.12.12.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
!
router rip
version 2
network 10.0.0.0
network 192.168.20.0
no auto-summary
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end
R3
R3#show run
!<output omitted>
!
hostname R3
!
!
enable secret class
!
no ip domain lookup
!
!
interface FastEthernet0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
no shutdown
!
interface FastEthernet0/1.13
encapsulation dot1Q 13
ip address 10.13.13.3 255.255.255.0
!
interface FastEthernet0/1.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
!
interface Serial0/0/0
no ip address
shutdown
clockrate 125000
!
interface Serial0/0/1
ip address 10.2.2.2 255.255.255.252
no shutdown
!
router eigrp 10
network 10.2.2.0 0.0.0.3
network 10.13.13.0 0.0.0.255
network 192.168.30.0
no auto-summary
!
router ospf 1
network 10.2.2.0 0.0.0.3 area 0
network 10.13.13.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
!
router rip
version 2
network 10.0.0.0
network 192.168.30.0
no auto-summary
!
banner motd ^CCUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
End
S1
S1#show run
!<output omitted>
!
hostname S1
!
!
enable secret class
!
no ip domain lookup
!
vlan 10,12,13,20,30
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1-1000 priority 24576
!
vtp mode server
vtp domain cisco
vtp password cisco
!
interface FastEthernet0/1
switchport trunk allowed vlan 10,12,13
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 10
swotchport mode access
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 12
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk allowed vlan 13
switchport mode trunk
!
interface vlan10
ip address 192.168.10.2 255.255.255.0
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 15
password cisco
login
!
End
S2
S2#show run
!<output omitted>
hostname S2
!
enable secret class
!
no ip domain lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vtp mode client
vtp domain cisco
vtp password cisco
!
interface FastEthernet0/1
switchport trunk allowed vlan 12,20
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 20
swotchport mode access
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 12
switchport mode trunk
!
interface vlan20
ip address 192.168.20.2 255.255.255.0
!
banner motd ^CCUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 15
password cisco
login
!
End
S3
S3#show run
!<output omitted>
!
hostname S3
!
enable secret class
!
no ip domain lookup
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
vtp mode client
vtp domain cisco
vtp password cisco
!
interface FastEthernet0/1
switchport trunk allowed vlan 13,30
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 30
swotchport mode access
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 13
switchport mode trunk
interface vlan30
ip address 192.168.30.2 255.255.255.0
!
banner motd ^CCUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 15
password cisco
login
!
end

martes, 15 de enero de 2013

CCNA 4: Teoria capitulo 1

WAN: 
  • Generalmente conectan dispositivos que están separados por un área geográfica más extensa que una LAN.
  • Los WAN utilizan los servicios de operadores
  • Utilizan conexiones "serial"
DTE: Equipo terminal de datos. El DTE se conecta al bucle local a través del DCE.

CSU/DSU: Es una linea digital que se conecta por fibra optica. Por una parte el CSU, es una unidad de servicio de canal y el DSU, es una unidad de servicio de datos y se encuentran combinados en una pieza.

Modem DSL: Se utiliza una señal analógica para codificar la información digital y demula la señal portadora para decodificar la información transmitida.


Los switch de una red conmutada de paquetes determina el siguiente enlace. Esto, lo puede hacer de dos maneras:
  • Por sistemas sin conexión (Conectionless)
  • Por sistemas orientados a la conexión

X.25 se encuentra en la Network layer
ATM y ADSL las encontraremos en la Data layer

PVC's: Circuito Virtual Permanente, es un circuito virtual que se establece permanentemente cuando los circuitos virtuales deben esta en uno todo el tiempo. Se diferencia del SVC (Switch Virtual Circuit) en el que la conexión se establece y se corta en función de si se ha completado la transmisión de datos.

ATM: Tiene una arquitectura basada en celdas, en lugar de tramas. Las celdas ATM contiene una longitud fija de 53 bytes.

VPN: Es una conexión encripatada entre redes privadas a través de una red pública como Internet. En vez de usar una linea de Capa 2 dedicada, utiliza conexiones virtuales llamadas VPN tunels, que enrutan a través de Internet desde una red privada a otra.

miércoles, 9 de enero de 2013

CCNA 4: Ejercicio 1.5.1

Solución de los Switches y routers del ejercicio 1.5.1:

Router CENTRAL:

CENTRAL#sh run
Building configuration...

Current configuration : 968 bytes
!
version 12.3
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CENTRAL
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
no ip domain-lookup
!

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description Link to BRANCH
 ip address 10.1.1.2 255.255.255.252
!
interface Serial0/0/1
 description Link to ISP
 ip address 209.165.200.226 255.255.255.252
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface Serial0/0/1
 network 10.1.1.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
banner motd ^CAUTHORIZED ACCESS ONLY^C
!
line con 0
 password cisco
 login
line vty 0 4
 password cisco
 login
!
end


Router BRANCH:

Router#sh run
Building configuration...

Current configuration : 1575 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1
 ip address 172.17.1.1 255.255.255.0
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 172.17.10.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.17.20.1 255.255.255.0
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 172.17.30.1 255.255.255.0
!
interface FastEthernet0/0.99
 encapsulation dot1Q 99 native
 ip address 172.17.99.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.1.1.1 255.255.255.252
 clock rate 64000
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface FastEthernet0/0.1
 passive-interface FastEthernet0/0.10
 passive-interface FastEthernet0/0.20
 passive-interface FastEthernet0/0.30
 passive-interface FastEthernet0/0.99
 network 10.1.1.0 0.0.0.3 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.17.10.0 0.0.0.255 area 0
 network 172.17.20.0 0.0.0.255 area 0
 network 172.17.30.0 0.0.0.255 area 0
 network 172.17.99.0 0.0.0.255 area 0
!
ip classless
!
line con 0
 password cisco
 login
line vty 0 4
 password cisco
 login
!
!
!
end


Router ISP:

ISP#sh run
Building configuration...

Current configuration : 1076 bytes
!
version 12.3
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP
!
enable secret 5 $1$wTX2$Antawj7kYElq0mN96ZxDK1
enable password cisco
!
interface FastEthernet0/0
 description Link to Web Server
 ip address 209.165.201.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 description Link to CENTRAL
 ip address 209.165.200.225 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.1.1.0 255.255.255.252 Serial0/0/1
ip route 172.17.1.0 255.255.255.0 Serial0/0/1
ip route 172.17.10.0 255.255.255.0 Serial0/0/1
ip route 172.17.20.0 255.255.255.0 Serial0/0/1
ip route 172.17.30.0 255.255.255.0 Serial0/0/1
ip route 172.17.99.0 255.255.255.0 Serial0/0/1
!
banner motd ^C
AUTHORIZED ACCESS ONLY^C
!
line con 0
 password cisco
 login
line vty 0 4
 password cisco
 login
!
end


Switch S1:

S1#sh run
Building configuration...

Current configuration : 1511 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
spanning-tree vlan 1,10,20,30,99 priority 4096
!
interface FastEthernet0/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/5
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 172.17.99.11 255.255.255.0
!
ip default-gateway 172.17.99.1
!
!
line con 0
 password cisco
 login
!
line vty 0 4
 password cisco
 login
line vty 5 15
 login
!
!
end


Switch S2:

S2#sh run
Building configuration...

Current configuration : 2377 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
interface FastEthernet0/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 172.17.99.12 255.255.255.0
!
ip default-gateway 172.17.99.1
!
!
line con 0
 password cisco
 login
!
line vty 0 4
 password cisco
 login
line vty 5 15
 login
!
!
end


Switch S3:

S3#sh run
Building configuration...

Current configuration : 1408 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S3
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
interface FastEthernet0/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 172.17.99.13 255.255.255.0
!
ip default-gateway 172.17.99.1
!
!
line con 0
 password cisco
 login
!
line vty 0 4
 password cisco
 login
line vty 5 15
 login
!
!
end